1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. PLEASE: Read the FORUM RULES BEFORE registering!

    Dismiss Notice

Taking the CNC Plunge

Discussion in 'PRECISION-MATTHEWS' started by TomS, Aug 6, 2014.

  1. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    That's what I thought. There's got to be something with how I've got it wired. I've got 5vdc on the control side and it powers up the LED indicator light. There's 240vac into the relay on the AC side but nothing coming out.

    That's wh
    That's what I thought. I'm not sure that the diagram is for the relays I've got. There's got to be a way to wire it so it will work.

    Tom S
     
  2. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I'll gather some info on the Z axis and post it. My gut is telling me it's a configuration issue but I need to read through the Mach 3 instruction manual again.

    Thanks,

    Tom S
     
  3. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Z axis settings -

    Steps per - 16297.08212

    Velocity - 49.998

    Acceleration - 15

    Velocity and acceleration are the same for all three axis. Steps per for X and y are about 5080 +/-.

    Like I said in my previous post I need to do some reading so I can understand the consequences of changing settings. It would seem logical to me that the Z axis acceleration should be lower than the X and Y because of the difference in weight. Am I on track with this logic or off base?

    Tom S
     
  4. JimDawson

    JimDawson Global Moderator Staff Member Director

    Likes Received:
    3,783
    Trophy Points:
    113
    City:
    Sandy
    State:
    Oregon

    -Return to Top-

    I would say you are correct. I would cut the accel by half and see what happens, maybe cut the speed to 25 also.
     
  5. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I'll give it a shot and report back.

    Tom S
     
  6. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    On the SSR, you have it wired correctly. I tested all my SSR's using a 110v lamp and breaking the load through the SSR. I would try this to verify the SSR is working. It may be that the SSR is not responding to switching one side of the 220v circuit.

    Jay
     
    JimDawson likes this.
  7. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    If you cannot get the SSR to work correctly with the 220v power supply's, I would suggest using the contactors that came with the mill. You have three of them and a 24vac transformer for the contactor coils.

    I use the contactors to power up the all the electrical in the machine with the original on / off buttons. Up until I switched to the VFD I was switching the spindle on/off with Mach 3 using an SSR to activate one of the contactors.

    Jay
     
  8. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    We have the same Z motor and driver. What are your dip switch settings on the Z driver?

    My motor settings in Mach3 are: Steps = 16253.xxxx, Velocity = 49.998, Acceleration = 10, step pulse = 5, dir pulse = 5

    My gut feeling is you may have a wiring issue.

    My dip switch settings.

    IMG_0002.JPG
     
  9. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I could use the contactors and that would solve the problem. But it bugs the hell out of me that it doesn't work and I don't know why.

    Tom S
     
  10. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I'll give this a try and see what happens. Thanks for the idea.

    Tom S
     
  11. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Here's a picture of my dip switch settings. They're different than yours. I'll need to look at the driver manual to see how these different settings affect motor performance. My steps are set the same, or nearly the same as yours. Mine are 16K plus but at the moment I don't have access to my computer with Mach 3 on it to verify the exact number. Velocity is the same but acceleration is set at 15. Step pulse and dir pulse are both set at 5. I did test the motors on the bench and all three turned in both directions. Obviously that's with no load. What should I be looking at in the wiring that might be causing this? I truly appreciate everyone's help. Thanks.

    Tom S


    DSCF1800.JPG
     
  12. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    Your dip switch settings are the same as mine so you should be okay with that.

    Check all your wire termination points at the motor, drive, power supply, BOB and panel connectors if you are using them. It's possible a wire does not have a solid connection at one of these points.

    The 4200 oz stepper moves my mill head likes its not there.

    Jay
     
  13. JimDawson

    JimDawson Global Moderator Staff Member Director

    Likes Received:
    3,783
    Trophy Points:
    113
    City:
    Sandy
    State:
    Oregon

    -Return to Top-

    I don't understand why the SSR doesn't work either, you have it wired correctly. As jbolt suggested, I would wire up a lamp and see it it will turn that on. The other thing I would do is put a 10mF capacitor across the 5 volt as a filter and see if that has any effect on the operation.
     
  14. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    It may be that the power supply is not drawing enough current to turn the SSR on. It's my understanding if the SSR does not see a minimum current from the load they won't turn on.

    Jay
     
    JimDawson likes this.
  15. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Got to help a neighbor with a landscape project today. Won't get to testing the SSR or checking wiring until tomorrow. Thanks to all for your input.

    Tom S
     
  16. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I checked all of the Z axis wiring to make sure I had good connections. Removed all of the control and power wires and ran continuity checks. All were good including the aviation plugs. So I fired it back up and when I reset the E-stop an error dialogue box popped up that said UC100 did not respond. I checked the connections and restarted Mach 3. Made sure the green and blue UC100 lights were lit and hit the E-stop button. Again I got the same error dialogue box. Restarted Mach 3 and selected the Plugin Control button, then clicked on UC100. Got another error dialogue box that said "UC100 not found. Please check the connection and restart Mach 3!" Restarted again and was able to open the UC100 I/O monitor. I noticed that the Max step rate was set at 100k Hz. This setting was different than the kernel speed setting in the Motor Tuning section, which was 25k Hz. I changed the kernel speed setting in the UC100 to match the motor tuning setting and closed the UC100 I/O monitor. Restarted Mach 3 again and now the E-stop will not reset. So I guess I will go back into the UC100 I/O Monitor and change the kernel speed back to 100k Hz even though the UC100 instructions are clear that the motor tuning and UC100 settings need to match. Sheesh! This is frustrating.

    By the way I tested all four of my SSR's by using a lamp. Same for all four, no power to the lamp. So if the SSR needs to see current draw from the power supplies how is that done? Do you configure the motors to be in a braking mode at startup?

    I did reset the Z axis motor tuning to about 25 velocity and 7 on acceleration. Haven't been able to test it yet because of the E-stop issues.

    Tom S
     
  17. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    Sorry you are having so much trouble. I know how frustrating it is.

    Are you saying the SSR's worked with the lamp or not?

    On the UC100, are you powering up all 3 axis at the same time or only one axis at a time for testing? I had a similar issue when one of the power supplies did not power on and the UC100 would fault. If you are testing one axis at a time with the power off to the other axis be sure to disable the other axis in Mach3.

    Jay
     
  18. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    Also, change Mach3 to 100k on the port setup page.

    Jay
     
  19. JimDawson

    JimDawson Global Moderator Staff Member Director

    Likes Received:
    3,783
    Trophy Points:
    113
    City:
    Sandy
    State:
    Oregon

    -Return to Top-

    I suspect that the kernel setting has nothing to do with the E-stop unless the UC100 is sending some kind of an error to Mach. I would look at the E-stop setting in Mach

    I assume you are trying to turn on a known good, 60 Watt or so, 120V lamp with the SSRs. If they won't turn that on then I would say there is a major problem with the SSRs. The power supplies draw more than enough start up current to turn on the SSRs
     
  20. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    The SSR's did not work with the lamp.

    I'm powering up all three axis at the same time. But I do have good news. The two screws on the ends of the Z axis power supply/driver terminal block were loose. I turned them down about 4 turns to get them tight. After doing this the Z axis moves up and down and the UC100 error code doesn't come up. Evidently the terminal block wasn't making a good connection and tightening the screws cured it. We'll see.
     
  21. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    So Mach 3 and the UC100 should both be 100k kernel speed. Correct?
     
  22. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Yes, it is a 100 watt bulb. Seems strange that all four are bad.

    See my post to jbolt about the Z axis terminal block. Problem cured I hope.

    Next is the limit/homing settings. I wired the switches in series and wired the two leads into the BoB. That caused the E-stop to activate and I couldn't reset it. I don't think this is a problem yet because there are no settings yet in Mach 3 for limits. I'll read up on this subject tonight and attack it in the morning.

    Thank to you and jbolt for your help.

    Tom S
     
  23. jbolt

    jbolt United States Active User H-M Supporter-Premium

    Likes Received:
    895
    Trophy Points:
    113
    City:
    Mountain View
    State:
    California

    -Return to Top-

    That great news! I'm glad you found it.

    That's crazy that all the SSR's don't work? What low volt DC source were you using to test, the 5v or 12v?

    Jay
     
  24. JimDawson

    JimDawson Global Moderator Staff Member Director

    Likes Received:
    3,783
    Trophy Points:
    113
    City:
    Sandy
    State:
    Oregon

    -Return to Top-

    I agree, that is crazy. Just for a test, try to turn on the SSRs with a 9 or 12 volt battery. If they work, then I suspect that the DC coming from your wall wart is not filtered and needs a capacitor across the 5Volt terminals to take out the ripple.
     
  25. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I was using the 12vdc transformer. I could try the 5v transformer but I'm thinking I'll get the same results.
     
  26. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    I ran the lamp test using a 9 volt battery and the SSR turned on the light. The SSR's are good. So it looks like I need to get a 10mF capacitor for a filter.

    Tom S
     
  27. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Got the limit switch pin setting figured out. Pin 12 is the Input #3 on the BoB. I actuated each limit switch and got a limit switch activated message in the Status dialogue box. Pressed the Reset button and the message cleared. So this appears to be working.

    Next issue is the E-stop. I set the pin number to each of the available input pins. #12 pin seemed to be the logical choice as it is tied to the limit switches. However, when I push the reset button I get the dreaded UC100 communication error. I've read through the Mach 3 installation manual, the UC100 manual and the literature for my BoB and can't figure out what the correct settings should be. Do I check E-stop Active Low, do I need to select Auto Limit Overide, do I need to select Overide Limits, do I need to select Active Low on the limit switches? Maybe I'm completely off base here but I'm real close to making this thing run and getting anxious.

    Thanks,


    Tom S
     
  28. JimDawson

    JimDawson Global Moderator Staff Member Director

    Likes Received:
    3,783
    Trophy Points:
    113
    City:
    Sandy
    State:
    Oregon

    -Return to Top-

    You might also confirm that the output of the wall warts is DC, I have seen some that are AC output. I normally have to use a magnifying glass to see the data plate on the wall wart, but your eyes might be better than mine. :)
     
  29. TomS

    TomS Active User H-M Supporter-Premium

    Likes Received:
    415
    Trophy Points:
    83
    City:
    Redding
    State:
    California

    -Return to Top-

    Man, am I learning a lot about electricity and electronics! I just checked and found out the 12 volt transformer is AC output. That explains why it didn't turn on the SSR LED light. The transformer that is installed is 5VDC output and does power up the USB hub which feeds the SSR and the BoB. Still need the filter because the 9V battery powered up the SSR but the 5VDC transformer won't.

    Tom S
     
  30. bvd1940

    bvd1940 United States Active User Active Member

    Likes Received:
    26
    Trophy Points:
    48
    City:
    Blackfoot
    State:
    Idaho

    -Return to Top-

    Don't feel bad, you never let any magic smoke out did you? when the smoke escapes that's when you feel bad:chemist:
    I hope to get back to my project this week, yours looks to be moving right along nicely Tom.
    Bill
     

Share This Page